Jump to content
John escort mk1V6

Escort mk1V6 upgrades

Recommended Posts

So the boot is done for now , i did replace the battery and welded 4 hooks on the floor for the jack and stuff and i did welded the hole`s that did stay behind also from the return fuel line`s , there`s one left and that one i did fit on the fuel sender.

And i did removed the reinforcement strips on the floor that i put in on the old place for the batterty tray.

Later i am put a ohter fueltank in , without the 2 return pipe`s.

 

IMG_2650.JPG

kofferbak (4).JPG

kofferbak (8).JPG

 

 

kofferbak (12).JPG

kofferbak (11).JPG

IMG_2663.JPG

IMG_2661.JPG

IMG_2675.JPG

IMG_2674.JPG

IMG_2676.JPG

  • Like 2

Share this post


Link to post
Share on other sites

So did reshape the left innerwing to make some space for the airflowmeters and it looks the same as the right side were normal the battery tray sits

 

 

 

 

 

IMG_2738.JPG

IMG_2740.JPG

IMG_2741.JPG

IMG_2742.JPG

 

 

 

 

 

 

 

IMG_2747.JPG

IMG_2763.JPG

  • Like 2

Share this post


Link to post
Share on other sites

Thanks Ben , the next thing what i am gonna do is weld a plate in the front for the K&N airfilter with a box/pipe or something like that to mount against the airflow meters.

  • Like 1

Share this post


Link to post
Share on other sites

So have put in a new blowing fan and the big allow radiator , and i did make a plate for the airfilter for now later i will weld it in the new radiator suportplate [L + R oldskool style] also the front did needed some modifications.

In the meanwhile i did let weld the waterpipe on the radiator , becourse it did came alomost against the waterpump , the radiator builder did weld it on the wrong place.

The next thing will be to make a airbox.

 

IMG_2737.JPG

radiateur (3).JPG

radiateur.JPG

radiateur (2).JPG

IMG_2845.JPG

IMG_2846.JPG

IMG_2850.JPG

 

IMG_2847.JPG

IMG_2851.JPG

  • Like 2

Share this post


Link to post
Share on other sites
2 minutes ago, John escort mk1V6 said:

Thanks Ben , i have used the same filter on mine estate , nice cold air goes in with speed.

How does it cope in wet weather ?

Share this post


Link to post
Share on other sites

I hope good Colin , we wil see a little bit of rain is no problem i hope , but when it rains i ant gonna drive it , but some times it can be wet.

But theres comes a airbox against it , i think the water stays low , and there is oil on the filter.

 

Share this post


Link to post
Share on other sites

Something else I wanted to quiz you about was the use of Sierra anti roll bar. What and how you modified to fit as was looking to use a similar set up on my Anglia if it could be narrowed enough

Share this post


Link to post
Share on other sites

I have bought the 8G the stifest anti-roll bar/pushrods/wide clams bushes at Rally Design from a race siërra set-up complete with arms , and i have made it more narrow becourse a siërra is much wider and have changed the arms for the right angle , and i have weld it all together , normal its bolt together but i did get same play at it due drilling of the holes.

It is a pipe with massive bushes at the ends were the bolts normal sits.

memory stick 3175.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites

And the airbox is almost done it needs a paintjob or maybe a powdercoating , but i did expected that the rear airflowmeter would get more air than the front one so i did took the airhose to blow some air and yes the hole of the rear airflowmeter  blows harder , so what i are going to do is weld a plate in the airbox to bloc the airflow to the rear a bit.

But i am happy how it did turn out , it was a hole lot of work and i want to know how it sounds.

And have welded a plate in it and this works for now and i have painted black.

IMG_2869.JPG

IMG_2872.JPG

IMG_2878.JPG

IMG_2893.JPG

IMG_2901.JPG

IMG_2904.JPG

IMG_2916.JPG

IMG_2917.JPG

IMG_2931.JPG

IMG_2935.JPG

IMG_2936.JPG

IMG_2937.JPG

IMG_2938.JPG

IMG_2940.JPG

IMG_2941.JPG

IMG_2952.JPG

IMG_2951.JPG

IMG_2954.JPG

IMG_3028.JPG

IMG_3032.JPG

IMG_3035.JPG

  • Like 2

Share this post


Link to post
Share on other sites

And again something done , on the tunnel this time , the clutch lever didn`t have enough clearance it did almost the tunnel.

So i did remove the ugly piece of metal what did weld in years and year ago that was also a modivication at that time.

And now it looks much better and also the rubber cover was to tide so did grind it a bit on the in-side and out-side , so there is just enough clearance.

And flywheel wasn`t straight anymore , so of to the machineshop , and a new clutch goes in.

IMG_2681.JPG

IMG_2980.JPG

IMG_2983.JPG

IMG_2987.JPG

IMG_2989.JPG

IMG_3003.JPG

IMG_3011.JPG

IMG_2996.JPG

IMG_2978.JPG

IMG_3016.JPG

IMG_3018.JPG

IMG_3023.JPG

IMG_3026.JPGIMG_3028.JPGIMG_3031.JPGIMG_3029.JPG

IMG_3030.JPG

IMG_3042.JPG

IMG_3032.JPG

IMG_3035.JPG

  • Like 3

Share this post


Link to post
Share on other sites

I have done alot of things , like painted the valve covers/the plate above/towerbrace later i will pait the inlet manifold , put in new valve seals , make a nice shape copperpipe for the heater , i did replace the seat rails/suport [taunus tc1] and put on a higher suport bracket so the seats sits 5cm more to the rear , also i put back in the much smaller altenator from a fiesta , the radiator does work great , and the new deep steering wheel looks better the sparco complete with the rs logo the same as the wheelcaps and gearknob , also i have been working on the rear disc brakes but that doesn`t  work with the standard master brake cylinder but i will look at other later.

IMG_3066.JPG

IMG_3067.JPG

IMG_3070.JPG

IMG_3087.JPG

IMG_3089.JPG

IMG_3111.JPG

IMG_3113.JPG

IMG_3117.JPG

IMG_3077.JPG

rs velg.JPG

  • Like 2

Share this post


Link to post
Share on other sites

Looking good as always. 

What's your target completion date?

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, dt36 said:

Looking good as always. 

What's your target completion date?

Thanks dt36 i have not got a target date with this car , i want to drive now for the rest of this year i do drive with it allready and it drive better than before and faster , but there`s a small problem by idle that wasn`t there at the start so mayme there something broken due working on it [ignistion]and in the winter i want it technical in right order , and also i want to put on the 205-50-13 tyre`s instead of the 195-45-13 and do small jobs on it.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, John escort mk1V6 said:

Thanks dt36 i have not got a target date with this car , i want to drive now for the rest of this year i do drive with it allready and it drive better than before and faster , but there`s a small problem by idle that wasn`t there at the start so mayme there something broken due working on it [ignistion]and in the winter i want it technical in right order , and also i want to put on the 205-50-13 tyre`s instead of the 195-45-13 and do small jobs on it.

They are never finished... :-)

Share this post


Link to post
Share on other sites
19 minutes ago, Ben Perry said:

Good progress loving the wheels 

Thanks Ben , i have let them done years ago but the clearcoat must go off and than i gonna polish them , and the centercap domed sticks are special made.

  • Like 1

Share this post


Link to post
Share on other sites

And i have also put in the quarter windows , they were almost complete apart , so i took also the glas out of the frame.

I treaded al the metal with the sandblaster and i did paint it with filler and the right colour paint , weld the upper brackets to the frame and put in the glass with a sealant 

And i most say it was al hole alot work , but ik looks very good.

The rubbers did strink a bit so i have put on a sealer in the front angles , when these are dry i do the same with the rear angles , may be a make them warm so they stretch a bit better.

IMG_3204.JPG

IMG_3205.JPG

IMG_3216.JPG

IMG_3217.JPG

IMG_3218.JPG

IMG_3223.JPG

IMG_3221.JPG

IMG_3224.JPG

IMG_3230.JPG

IMG_3215.JPG

  • Like 2

Share this post


Link to post
Share on other sites

So i have got finally the rear discs brakes working , they did locking up after a 100 meters , becourse the brake pedal was pushed in.

But before this i have put in a spring in the master cilinder between the front and rear piston , becourse normal the springs from the brake shoes pusches the brake fluid back , and the piston from the front brakes has standard a spring , so now has the rear piston also a spring.

And the rear calipers was to close to the disc`s , so that same adtension , and seems to work now i did same driving/brake and they became hot and didn`t lock up after this , so now i must check out if the rear doesn`t brake to hard , i have already got brake pressure in it , so we will see.

And have put in other axle`s in from a mk1 big cologne diff , and i have also got rid off the old copper brake fluid line , it looks much better like this.

And i drive today and it brakes to hard at the rear , but the brakes difference left and right was good at the front it was 1% and later 0% at the it was 2%.

So i am after a brake presure valve , and i just bought the last one on ebay.uk

 

IMG_3233.JPG

IMG_3237.JPG

 

 

 

IMG_3239.JPG

IMG_3238.JPG

IMG_3107.JPG

IMG_3242.JPG

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×