Jump to content

Benjy✌

Members
  • Content Count

    193
  • Joined

  • Last visited

Community Reputation

76 Superb

About Benjy✌

  • Rank
    Old Skool & Loving It
  • Birthday 23/12/1995

Profile Information

  • Gender
    Male
  • Location
    Mars
  • Interests
    Anything retro with a blue oval!

Recent Profile Visitors

1,022 profile views
  1. Hello mate have you got any pics? Regards, Ben.
  2. NOW SOLD Ford Capri Mk3 LS car is in good condition for its age. There are a few bits here and there that require a little attention but it polishes up lovely and is very presentable for a 37 year old car. It’s recently just had a full detail and had the S graphics fitted. The interior is in lovely original condition with only a few minor imperfections. It’s running on 13inch Minilite wheels with Dunlop tyres that all have good tread. The 1600 pinto always fires up straight away and runs beautifully! It sounds very good through it’s 4 branch manifold and aftermarket exhaust system and is accompanied by a 4speed manual box. The car runs, drives and stops just as it should. There are some jobs that need doing, but overall it’s a perfect on the road project that you can jump in and use right away as it is and then get the bits done as and when. The car is currently Mot’d and is ready to be driven away or delivery anywhere within the U.K. can be arranged at a cost but the car will need to be paid for in full before it leaves. To arrange a viewing or anymore questions you may have regarding the car please message me. Thanks for looking. £4150ono SOLD.
  3. Here's my new toy, it's a 72 Mk3 Cortina 2door running a cologne V6, Real fun motor to drive!
  4. Got this reoccurring problem with my escort recently, basically it seems as if the solenoid is sticking and won't turn the car over! as soon as I give it a little tap with something it turns over and fires up like usual! Took me a while to establish exactly what the problem was as I first thought it was the starter sticking or a bad earth and it wasn't making that "clicking" sound that a solenoid usually does when they decide to pack up. Anyway I found the problem was with the solenoid so I stole one off my cortina which is practically new! I then put that one in the escort and it worked for a day or 2 then the same problem again! I can't work it out at all I checked all the connections and earthings multiple times and everything is tight and how it should be but it's just one of them small things that isn't making sense? Could it be the cold weather lol? The car is used daily! Anyone had this problem?
  5. Unfortunately it's a engine out job, had to change my sump gasket last month, there's 2bolts at the back of the sump that are impossible to get to as the bell housing was in the way, either way it's not a huge job, can be out and back in, in a hour with a helping hand
  6. They do panels for these but they are crazy money! It put me off getting one I was looking at a while back
  7. Cheers for the reply mate! Got in all in a running now! Goes very well!
  8. Hi I've got a mk2 1300 escort and I've got a 1600xflow lump in the garage, There's 2 different clutches online and I was just wondering if the 1600 clutch would fit in the 1300 box? Or do I have to use a 1300 clutch? Silly question I know haha
  9. Glad to hear a few people use there oldskool motors daily!
  10. Yeah that's right the guy we got it off says he blew the diff up that was in it so it had a strange one in, we've now fitted a 3:55 lsd and has had a few little engine upgrades now plan to run it regularly at the pod next year, it ran a low 15 in 2009 and that was the time it went on the strip it's on nitrous aswell now so we are hoping for a 13 next year
  11. Hi mate! Yeah I've been in contact with John recently he was telling us all the difficulties he had with the 351! It's running a 302 now and is wearing primer for a bit! Will be black eventually! Here's a few pics of it currently-
  12. Similar sort of thing happened to me a few weeks back! I posted a picture of my old mans mk1 zephyr on one of the Retards Club groups we've had it 10years now and a guy commented on the picture and it turns out he rebuilt it! He said he got the car in 1985 and told me loads of old stories. Here's some of the old build pics from the 80s he sent me Here was it when he finished it in 1994 He sold the car on in 2003 looking a bit tired and the reg was changed, the guy we go it off hadn't had it very long we got it 2005! The guy we got it off repainted it and it looked like this- It's good to know the history! Here is a picture of it now!
×
×
  • Create New...