Jump to content
knobrot

Mk2 escort wiring loom

Recommended Posts

Was one on Retards Club.....in Ireland. No price tho

Sent from my SM-G900F using Tapatalk

Share this post


Link to post
Share on other sites
On 13/08/2019 at 20:36, Monza said:

Was one on Retards Club.....in Ireland. No price tho

Sent from my SM-G900F using Tapatalk
 

Retards club ?

Share this post


Link to post
Share on other sites

There seems to be a loom boom going on?

Maybe we can pool our resources and find a supplier to properly copy them and buy all at once?

  • Like 1

Share this post


Link to post
Share on other sites

Ive laid mine out today connected a battery connect some earths and plugged everything in, as ive never seen my car run.

no indicators, no hazards, heater blows on 1 speed, no heat, headlights ok, no wiring for side lights at all. No interior light wiring, no washers and i still need to plug the rear loom in......

Share this post


Link to post
Share on other sites

I could do with one as well !! Just a standerd 1300/1600 rhd one would do . You would think nowerdays someone would be reproduceing them , theres a fortune to be made there .

Share this post


Link to post
Share on other sites

As i'm currently renewing my entire loom on my RS2, all I can say as they are incredibly complicated and more or less totally illogical in regard the stalk switchgear and the fusebox distribution. Colours are not consistent through the loom and vary from those stated on the available schematics! I'm about 50% done now, then i've the EFI wiring to do - what could possibly go wrong? One thing in the original looms that wouldn't be economically viable with reproduction looms - the weight of copper used! There are lots of sections of 3, 4 and 5mm cable whereas modern looms rarely use anything more than 2mm!

Share this post


Link to post
Share on other sites

Greame at G S Escorts put me onto Auto Sparks. They make wiring harnesses for most classic cars....look very good, but pretty pricey if you need it all. Worth a look tho....

Sent from my SM-G900F using Tapatalk

Share this post


Link to post
Share on other sites

Yeah,

i had seen  these already.

quite pricey but probably a sensible investment in the long term. Just more than I wanted to spend at the moment with the car eating more money than I’m earning at the moment 

 

Phil

Share this post


Link to post
Share on other sites

The available wiring diagram for the mk2 escort is the worst I’ve ever seen. It may be me but I’m unable to follow the wires from where they go into a central line as it looks on the drawing and get where it comes out 🤔 unlike previous wiring diagrams I’ve had you can follow every individual wire from start to finish inc colour change and T offs to supply other things on the same circuit. If I could I’d be re- making my own harness as I did on the Tina and the Anglia also the engine loom on the cossy. With Katanas reports on the issues he’s had with his harness I would be having more than second thoughts on paying a lot of money for a harness that basically a lump of wires and no traceable connect ability to switchgear or other units using the original a Ford drawing.

Share this post


Link to post
Share on other sites

Given im on a budget, Ive gone for a second hand loom, hopefully I can make one good loom from 2, we’ll see.....

Share this post


Link to post
Share on other sites

Second hand loom arrived yesterday, looks in better condition than my old one, so plugged everything in and see what i get.

extra terminal on headlight switch, i suspect this may be for factory sport lights? Also wiring to this switch is coloured differently, deep joy.

missing wiring for extra relay for intermittent wipe, another issue to solve.

More fun on the way i fear......

Share this post


Link to post
Share on other sites

Night..... mare

 

so, loom altered, I now have intermittent wipe, but no washers. Looks  like a dodgy switch.

the new loom has more plugs on than the original, so thats good.

old loom had domestic 3 core used to headlights, not a wire in sight for front side lights....

new loom has all headlight feeds cut for what must have been a relay? Not professionally done.

 

this could be a long job

 

Share this post


Link to post
Share on other sites

Long slow process in my experience.... and that was just re-installing my original loom, trying to work out what's there and what isn't and why!! Never mind using 2 looms to make 1...enjoy
Great when finally sussed and everything works as it should

Sent from my SM-G900F using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...